2006年10月 7日

perl module のインストール

自宅サーバーでもMovableTypeを動かしてみるために、必要なPerlのモジュールを入れてみました。
無くても構わないモジュールもありましたが、この際、可能な限りのモジュールを入れることにして、

# apt-get install perl-HTML-Parser
# apt-get install ImageMagick-perl
# apt-get install perl-XML-SAX
# apt-get install perl-XML-Parser

とすると、mt-check.cgi によるモジュールのチェックで、
Crypt::DSA 以外がOKとなりました。
Crypt::DSA は vineのパッケージが判らなかったので、cpanを使って

# perl -MCPAN -e shell

cpan> install Crypt::DSA

でインストール出来ましたが、最初すごく時間が掛かって途中で中止してしまいました。
50分くらい掛かるとの情報を得たので、再度、cpanでインストールして、しばらく放っておいたら、無事、完了。

試してはいませんが、

# apt-get install perl-Crypt-DSA

で行けるかもです。